Can not backup Carousel database
January 5, 2021
Applies to
- Carousel 7.0.0 - 7.4.8
Symptoms
- You receive an error stating "Could not back up database carousel50;multipleactiveresultsets=true. Incorrect syntax near 'multipleactiveresultsets'...."
Cause
This issue is caused by a software bug within the FrontDoor application. The piece of code that detects the name of the Carousel database within SQL server is incorrectly interpreting the database name as "carousel50;multipleactiveresultsets=true" instead of "carousel50"
Workaround
- From the Windows desktop of your server navigate to C:\TRMS\Configuration\
If you don't see a C:\TRMS\Configuration\ folder, check D:\TRMS\Configuration\ - Open connectionStrings.config in notepad.
- Find the following entry
connectionString="data source=(local);Integrated Security=SSPI;initial catalog=Carousel50;MultipleActiveResultSets=true;"
- Change the entry to match this configuration order:
connectionString="data source=(local);Integrated Security=SSPI;MultipleActiveResultSets=true;initial catalog=Carousel50;"
- Save the file
- Restart IIS
- You should now be able to backup the database.